Search

Language:  
Search for:

Available article translations:

ERROR: Unable to check for updates

APPLIES TO:
  • Parallels Desktop 10 for Mac Standard Edition
  • Parallels Desktop 9 for Mac Standard Edition
  • Parallels Desktop 8 for Mac Standard Edition
  • Parallels Desktop 7 for Mac Standard Edition

Symptoms

You are not able to download Parallels Desktop updates with the following error message:

    Unable to check for updates

or

    Unable to connect to the Parallels Update site. Please check your Internet connection and try again

Cause

You may have a faulty update domain listed in your local hosts file which prevents Parallels Desktop to update.

This problem also may be caused by proxy being turned on and being used on the host side.

Resolution

In order to resolve the issue follow the steps below:

  1. If you have proxy turned on in your Mac - please turn it off at:
    System Preferences > Network > Advanced - Proxies
    And restart your Mac.
  2. Open Applications > Utilities > Terminal and run the command below:

        cat /etc/hosts
    
  3. Examine the output for similar entries (the output may be slightly different):

    127.0.0.1       pdfm.blist.parallels.com
    127.0.0.1       pdfm.vl.parallels.com
    127.0.0.1       registration.parallels.com
    127.0.0.1       update.parallels.com
    
  4. In case such entries are present in your hosts file, remove them. To do it type it in Terminal:

    sudo perl -pi -w -e 's/127.0.0.1/#127.0.0.1/g;' /etc/hosts
    echo “127.0.0.1 localhost” | sudo tee –a /etc/hosts”`
    

Search words:

CSL

PD Pro Edition

PD Business

PD




1e5db16426987d561060acdf56d947b4 df4909b7dd0609a3c148f007041db6d9 3307fff3682b15f0ba3fbe13d779296d ae069407387ff6d2cdd44f3842d61cf7 97cd84747b25a2e5a06065a21a747a53 223eaea75536b1878213dd8e38ab608d

FEEDBACK
Was this article helpful?
Tell us how we may improve it.
Yes No