Search

Language:  
Search for:

Available article translations:

ERROR: Unable to check for updates

APPLIES TO:
  • Parallels Desktop 10 for Mac
  • Parallels Desktop 9 for Mac
  • Parallels Desktop 8 for Mac
  • Parallels Desktop 7 for Mac

Symptoms

You are not able to download Parallels Desktop updates with the following error message:

    Unable to check for updates

or

    Unable to connect to the Parallels Update site. Please check your Internet connection and try again

Cause

You may have a faulty update domain listed in your local hosts file which prevents Parallels Desktop to update.

This problem also may be caused by proxy being turned on and being used on the host side.

Resolution

In order to resolve the issue follow the steps below:

  1. If you have proxy turned on in your Mac - please turn it off at:
    System Preferences > Network > Advanced - Proxies
    And restart your Mac.
  2. Open Applications > Utilities > Terminal and run the command below:

        cat /etc/hosts
    
  3. Examine the output for similar entries (the output may be slightly different):

    127.0.0.1       pdfm.blist.parallels.com
    127.0.0.1       pdfm.vl.parallels.com
    127.0.0.1       registration.parallels.com
    127.0.0.1       update.parallels.com
    
  4. In case such entries are present in your hosts file, remove them. To do it type it in Terminal:

    sudo perl -pi -w -e 's/127.0.0.1/#127.0.0.1/g;' /etc/hosts
    echo “127.0.0.1 localhost” | sudo tee –a /etc/hosts”`
    

Search words:

CSL

PD Pro Edition

PD Business

PD




1e5db16426987d561060acdf56d947b4 33c4522b6fa9ca8e050f19b889fb58f1 48e7cf384e3b46432e32e6040476f122 fb0e3c3e2247964007f03acae43ffd0d 790d27220dd34433ff172f45c18cfb98 1e0c43ccf6ca78fa6744efc9edbc0659

FEEDBACK
Was this article helpful?
Tell us how we may improve it.
Yes No