Search

Language:  
Search for:

Available article translations:

How to update PHP 5.x EZ template on a Container to version 5.3

APPLIES TO:
  • Parallels Plesk 11.x for Linux
  • Parallels Plesk 10.x for Linux
  • Parallels Plesk 9.5 for Linux/Unix
  • Parallels Virtuozzo Containers for Linux 4.6
  • Parallels Virtuozzo Containers for Linux 4.0

Symptoms

I have a Container with the "php5" EZ template on it. When I try to install the "pp10-php53" EZ template to that Container, the installation fails with the following error:

--> Processing Conflict: php53-common conflicts php-common
--> Finished Dependency Resolution
php53-common-5.3.3-1.el5_6.1.i386 from base5 has depsolving problems
  --> php53-common conflicts with php-common
Error: php53-common conflicts with php-common

Note:
The article applies to Parallels Virtuozzo Containers versions based on CentOS 5.x and Parallels Plesk Panel version 9.5.4 and later versions.

Resolution

1. Download the template below which corresponds to your Container's architecture:

pp-php53-update-centos-5-x86-ez-3.0.0-36.prl.308079.noarch.tar.gz
MD5 SUM: 1fb73386281d1429458a70a3ae5d860b

pp-php53-update-centos-5-x86_64-ez-3.0.0-36.prl.308079.noarch.tar.gz
MD5 SUM: bfeec658e6360f5636351319478ceaa6

2. Install it to the Hardware Node.

3. Update PHP on the Container by installing the above template to it:

# vzpkg install CTID pp-php53-update

Additional information

- The template is not for standalone installation to a Container and must be installed either on a Container with Parallels Plesk Panel, or in the same transaction with other Parallels Plesk Panel templates.

- The template cannot be installed to Containers where the php53 template is already present; if attempted, the installation will fail.

- The template must not be installed in the same transaction with the pp{*}-php53 template; if attempted, the template will be installed, but the transaction will be marked as "failed," and the installed templates will not be registered on the Container.

- PHP 5.3 installation is performed by means of the autoinstaller utility, using this command:

# /usr/local/psa/admin/sbin/autoinstaller --select-release-current --install-component php53

As the packages are installed inside the Container, an insignificant increase of disk space usage will occur.
The autoinstaller utility also needs virtual memory in amounts of up to 200 MB on some operating systems. If the template installation fails due to lack of memory (failcnt value will increase in /proc/user_beancounters), increase the amount of memory available to the Container and retry the procedure.


Attachments:


1d8a9cb4444e61c9ccb3798e22c5f50c c81e59b61af9dca603ba03b14aabe968 9f8baf78266b4e54525d1c6bf06305a5 12c6f6bd6775cb701defb57d79fe96f6 1d151d16e47c6f92bbf62d50eb32c4a2 909d99074e442b52ce54cc7b31cf065d eb0ea3b827d18de2329b6477e24c1d59 219be54dff19e220f37105b0000118f4 9bccb04d0396d587d8123e5e12b4740e 824237ce663843af86f93897fbd8e2f8 2897d76d56d2010f4e3a28f864d69223 56797cefb1efc9130f7c48a7d1db0f0c

FEEDBACK
Was this article helpful?
Tell us how we may improve it.
Yes No
 
 
 
 
 
 
Desktop Virtualization
- Parallels Desktop 9 for Mac
- Parallels Transporter
- Parallels Desktop Switch to Mac Edition
- Parallels Desktop for Mac Enterprise Edition
- Parallels Management-Mac for Microsoft SCCM
Server Virtualization
- Parallels Cloud Server
- Parallels Containers for Windows 6.0 Beta
- Parallels Virtuozzo Containers
Automation
- Parallels Automation
- Parallels Automation for Cloud Infrastructure
- Parallels Business Automation Standard
- Parallels Virtual Automation
- Parallels Plesk Panel Suite
- Web Presence Builder
- Parallels Plesk Automation
- Parallels Small Business Panel
- Value-added Services for Hosters
- Parallels Partner Storefront
Services & Resources
- Cloud Acceleration Services
- Professional Services
- Support Services
- Training & Certification