Search

Language:  
Search for:

Available article translations:

Virtuelle Maschine kann nicht gestartet werden, da eine oder mehrere Kernel-Komponenten für eine andere Version von Parallels Desktop bestimmt sind

APPLIES TO:
  • Parallels Desktop 11 for Mac
  • Parallels Desktop 10 for Mac
  • Parallels Desktop 9 for Mac
  • Parallels Desktop 8 for Mac

Kennzeichen



Sie können eine virtuelle Maschine nach Upgrade auf Parallel Desktop 8 nicht starten und erhalten die Fehlermeldung:



Ursache

Parallels Desktop 7 kext-Dateien wurden nicht korrekt entfernt

Lösung

  • Entfernen Sie das Programm Parallels Desktop 8 mithilfe von Terminal.app aus Programme/Dienstprogramme. Fügen Sie dazu die unten aufgelisteten Befehle so wie sie sind in das Terminal ein (nacheinander; drücken Sie die Enter-Taste nach jedem Befehl). Ihre virtuellen Maschinen werden nicht gelöscht. Hinweis: Sie müssen su-Berechtigungen erhalten, damit die Befehle ausgeführt werden. Der erste Befehl lautet:
sudo su
(geben Sie anschließend Ihr Administratorpasswort ein und drücken Sie die Enter-Taste. Nun können Sie die unten aufgeführten Befehle eingeben)

for pid in $(ps aux | grep "Parallels Desktop.app" | awk '{print $2}'); do echo kill -KILL $pid; done

for kext in $(kextstat | grep parallels | awk '{print $6}'); do kextunload -b $kext; done

rm /System/Library/Extensions/prl*

rm -rf "Parallels Desktop.app"
 

  • Führen Sie die gleichen Schritte aus, um alle Komponenten von Parallels Desktop 7 zu deinstallieren. Fügen Sie die unten aufgelisteten Befehle so wie sie sind in das Terminal  ein (nacheinander; drücken Sie die Enter-Taste nach jedem Befehl). 
Hinweis: Wenn das Terminal keine Ausgabe anzeigt, nachdem Sie den Befehl ausgeführt haben, bedeutet das, dass der Befehl erfolgreich durchgeführt wurde.
Wenn Sie die Meldung 'No such file or directory' sehen, bedeutet dies, dass die Datei oder das Verzeichnis von dem regulären Deinstallationsprogramm entfernt wurde und Sie können fortfahren.
sudo launchctl stop com.parallels.vm.prl_naptd
sudo launchctl stop com.parallels.desktop.launchdaemon
sudo launchctl stop com.parallels.vm.prl_pcproxy


sudo kextunload -b com.parallels.kext.prl_hypervisor
sudo kextunload -b com.parallels.kext.prl_hid_hook
sudo kextunload -b com.parallels.kext.prl_usb_connect
sudo kextunload -b com.parallels.kext.prl_netbridge
sudo kextunload -b com.parallels.kext.prl_vnic
sudo kextunload -b com.parallels.filesystems.prlufs


sudo rm -rf /Library/Parallels
sudo rm -rf /Applications/Parallels\ Desktop.app
sudo rm -rf /Library/LaunchDaemons/com.parallels.desktop.launchdaemon.plist
sudo rm -rf /Library/LaunchAgents/com.parallels.*
sudo rm -rf /Library/Python/*/site-packages/prlsdkapi
sudo rm -rf /usr/bin/prl_perf_ctl
sudo rm -rf /usr/bin/prlctl
sudo rm -rf /usr/bin/prlsrvctl
sudo rm -rf /usr/bin/prl_disk_tool
sudo rm -rf /usr/share/man/man8/prl*
sudo rm -rf /var/db/Parallels/Stats/ParallelsDesktop.*
sudo rm -rf /usr/lib/parallels
sudo rm -rf /Library/Filesystems/prlufs.fs

sudo rm -rf /Library/Preferences/Parallels
sudo rm -rf /Library/Logs/parallels


  • Gehen Sie zu Programme --> Dienstprogramme --> Festplatten-Dienstprogramm, wählen Sie Ihr Mac Festplattenlaufwerk aus und wählen Sie die Option Zugriffsrechte reparieren.

  • Starten Sie Ihren Mac neu.




790d27220dd34433ff172f45c18cfb98 1e5db16426987d561060acdf56d947b4 33c4522b6fa9ca8e050f19b889fb58f1 48e7cf384e3b46432e32e6040476f122 fb0e3c3e2247964007f03acae43ffd0d 2869cc5960830411a19edd345e3e11d8

FEEDBACK
Was this article helpful?
Tell us how we may improve it.
Yes No