Search

Language:  

Available article translations:

要将硬盘从现有的虚拟机转移到空的虚拟机上

APPLIES TO:
  • Parallels Desktop for Mac Business Edition
  • Parallels Desktop for Mac Home Edition
  • Parallels Desktop for Mac Pro Edition

问题

我需要将硬盘从现有的虚拟机转移到空的虚拟机上。

原因

我现有的虚拟机在更新/升级后出现问题。

解决方案

按照以下步骤移动虚拟硬盘。请慎用此解决方案,因为所有虚拟机信息都存储在虚拟硬盘中。

1.关闭原虚拟机。

2.在 Parallels Desktop 菜单栏中,转至*文件* > 新建 > 从 DVD 或镜像文件安装 Windows 或其他操作系统,然后点击*手动查找*。

3.勾选*没有指定源也继续,并点击继续*。

4.选择适当的操作系统 > 选择适当的视图 > 勾选*安装前自定义设置* 并点击*继续。当新*虚拟机配置窗口出现时,不要关闭。

5.打开控制中心(窗口菜单 > 控制中心)。点击原虚拟机旁边的齿轮图标,以便打开其配置。

6.将新虚拟机的设置与原虚拟机的设置进行比较。按照原虚拟机的设置来进行新虚拟机的各项设置。然后,关闭原虚拟机配置窗口。

7.在新虚拟机配置中,转至*硬件选项卡 > 硬盘 1。将设置为选择一个镜像文件*。

8.导航至虚拟机位置目录(默认文件夹为 /Documents/Parallels//Users/Shared/Parallels/,视具体情况而定),打开*原*虚拟机的 .pvm 捆绑包,并选择该捆绑包中的 .hdd 文件。还要确保获得的位置类型与原虚拟机配置中的位置类型相同。

9.关闭设置并完成虚拟机安装。新虚拟机将会启动。确保新虚拟机可正常工作,然后关闭它。

10.打开新虚拟机的位置文件夹(打开控制中心 > 右击新虚拟机 > 在 Finder 中显示),右击 .pvm 捆绑包并选择*显示包内容*。删除 .hdd 文件。

11.同时,在另一个 Finder 窗口中打开原虚拟机的 .pvm 捆绑包。

12.将 .hdd 文件从*原始* .pvm 捆绑包拖放到*新的* .pvm 捆绑包。还要拖放*快照*和 Snapshots.xml(如果有)。

13.对新虚拟机执行第 5 步、第 7 步和第 8 步,以便为 .hdd 选择新的位置。

14.转移 .hdd 文件后,启动新虚拟机,并检查它是否可正常工作。

15.从虚拟机列表中删除原虚拟机:右击原虚拟机 > 删除 > 移动到废纸篓

16.可在*配置* > 常规 > 名称中更改虚拟机名称。




1e5db16426987d561060acdf56d947b4 a9c6e0b6a5209e617a7c0dd5eace86cf f9b6a8d63f3437e0dca35c9704a9033c 4987860c21de5849bcebfeb0472cfd03

FEEDBACK
Was this article helpful?
Tell us how we may improve it.
Yes No