Search

Language:  
Search for:

  • Article for your preferred language does not exist. Below is international version of the article.
Available article translations:

How to upgrade PBA-S system to the latest available version

APPLIES TO:
  • Parallels Business Automation - Standard

Resolution

Before starting the Parallels Business Automation - Standard (PBA-S) (formerly HSPcomplete) upgrade procedure, it is recommended you create a complete system backup, or at least a complete database dump (for minor upgrades on the same major version).

The upgrade steps depend on the currently installed version of PBA-S. You can find the currently installed version in the Provider's Control Center at Top > Support.

To upgrade from a PBA-S 3.2.x system, please submit an upgrade request using the Upgrade Request form.

  1. Create a fresh backup of the PBA-S system before upgrading using the instructions from this KB article.

  2. For the following PBA-S versions (not the latest 3.3.0 version):

    • 3.3.0-400.03
    • 3.3.0-401.10
    • 3.3.0-402.10
    • 3.3.0-403.22
    • 3.3.0-404.15
    • 3.3.0-405.22
    • 3.3.0-406.07
    • 3.3.0-407.22
    • 3.3.0-408.14
    • 3.3.0-409.11

    Upgrade to the latest PBA-S 3.3.0-410.xx version using the upgrade instructions from the Release Notes (section "(06) Installation instructions"), or continue to the next step to upgrade to the latest version.

  3. For the following PBA-S versions (including the latest 3.3.0 version but not the latest 3.3 SP1 version):

    • 3.3.0-410.XX
    • 3.3.1-00.179
    • 3.3.1-01.02
    • 3.3.1-01.06
    • 3.3.1-02.19
    • 3.3.1-03.08
    • 3.3.1-04.07
    • 3.3.1-05.05
    • 3.3.1-06.07

    Upgrade to the PBA-S 3.3.1 version (Service Pack 1) using the upgrade instructions from the Release Notes, or continue to the next step to upgrade to the latest version.

  4. For the following PBA-S versions (the latest 3.3.1 (3.3 Service Pack 1) version, not the latest 3.3 SP2 version):

    • 3.3.1-07.xx
    • 3.3.2-00.xx
    • 3.3.2-01.xx
    • 3.3.2-02.xx
    • 3.3.2-03.xx
    • 3.3.2-04.xx
    • 3.3.2-05.xx

    Upgrade to the latest available PBA-S 3.3.2 version (Service Pack 2) using the upgrade instructions from the Release Notes.

  5. For the following versions (the latest PBA-S 3.3.2 Service Pack 2 version, not the latest PBA-S 3.3.3 Service Pack 3):

    • 3.3.2-06.09
    • 3.3.3-00.xx
    • 3.3.3-01.xx
    • 3.3.3-02.xx
    • 3.3.3-03.xx
    • 3.3.3-04.xx
    • 3.3.3-05.xx
    • 3.3.3-06.xx

    For upgrades from 3.3.2-xx to 3.3.3-xx versions only, execute the upgrade precheck script as described in this article, or upgrade to the PBA-S 3.3.3-07.23 (Service Pack 3) version using the upgrade instructions provided in the Release Notes.

  6. For the following version:

    • 3.3.3-07.xx

    Upgrade to the PBA-S 3.3.8-39 version using the upgrade instructions provided in the Release Notes.

  7. For the following version:

    • 3.3.8-39

    Upgrade to the PBA-S 3.4 version using the upgrade instructions provided in the Release Notes.

  8. For the following version:

    • 3.4-29

    Upgrade to the PBA-S 4.0 version using the upgrade instructions provided in the Release Notes.

  9. For the following version:

    • 4.0-66

    Upgrade to the PBA-S 4.1 version using the upgrade instructions provided in the Release Notes, and install the latest PBA-S 4.1.6 update. Refer to this article: PBAS 4.1 updates list

  10. For the following version:

    • 4.1.6-09

    Upgrade to the PBA-S 4.2.1 version using the upgrade instructions provided in the Release Notes, and install the latest PBA-S 4.2.2 update. Refer to this article: PBAS 4.2 updates list

  11. For the following versions:

    • 4.2.2-03
    • 4.3-55

    Upgrade to the PBA-S 4.3.1 version using the upgrade instructions provided in the Release Notes.

  12. For the following versions:

    • 4.3.1-12
    • 4.3.3-47

    Upgrade to the PBA-S 4.3.4 version using the upgrade instructions provided in the Release Notes.

  13. For the following version:

    • 4.3.4
    • 4.5-55

    Upgrade to the PBA-S 4.5.1 version using the upgrade instructions provided in the Release Notes, and migrate the PBA-S Management Node to CentOS 6.x x86_64 if you have not migrated yet. For more details, refer to this KB article.

  14. For the following version:

    • 4.5.1-15

    Upgrade to the PBA-S 4.5.2 i386 or x86_64 version using the upgrade instructions provided in the Release Notes, and migrate the PBA-S Management Node to CentOS 6.x x86_64 if you have not migrated yet. For more details, refer to this KB article.

Search words:

upgrade PBA-S to the latest version

none

remove inactive virtuozzo nodes

Your payment has been saved, but cannot be applied due to the following error: Customer's profile was not reviewed

Error in response: 1. The cert cannot be configured because it is not in a valid status.

upgrade

database unavilable




4f06e569887915c59ae1fa4680142e7f caea8340e2d186a540518d08602aa065

FEEDBACK
Was this article helpful?
Tell us how we may improve it.
Yes No
 
 
 
 
 
 
Desktop Virtualization
- Parallels Desktop 9 for Mac
- Parallels Transporter
- Parallels Desktop Switch to Mac Edition
- Parallels Desktop for Mac Enterprise Edition
- Parallels Management-Mac for Microsoft SCCM
Server Virtualization
- Parallels Cloud Server
- Parallels Containers for Windows 6.0 Beta
- Parallels Virtuozzo Containers
Automation
- Parallels Automation
- Parallels Automation for Cloud Infrastructure
- Parallels Business Automation Standard
- Parallels Virtual Automation
- Parallels Plesk Panel Suite
- Web Presence Builder
- Parallels Plesk Automation
- Parallels Small Business Panel
- Value-added Services for Hosters
- Parallels Partner Storefront
Services & Resources
- Cloud Acceleration Services
- Professional Services
- Support Services
- Training & Certification