Symptoms
Parallels Tools installation rolls back without returning any error message or giving general Parallels Tools update error message.
To determine the cause of the rollback, you need to open the log file at C:\Windows\Temp\parallels-tools-setup.log. It will contain the following string:
Error code 0xE0000100: The style of the INF is different than what was requested.
Sample:
DIFXAPP: INFO: Installing INF file 'C:\Program Files\Parallels\Parallels Tools\Drivers\prl_dd\prl_dd.inf' (Plug and Play). DIFXAPP: INFO: Looking for Model Section ... DIFXAPP: INFO: Installing devices with Id "PCI\VEN_1AB8&DEV_4005&SUBSYS_04001AB8&REV_00" using INF "C:\Windows\System32\DriverStore\FileRepository\prl_dd.inf_x86_neutral_caed5e8e38ace253\prl_dd.inf". DIFXAPP: INFO: Will force install because driver is not better and force flag is set. DIFXAPP: INFO: ENTER UpdateDriverForPlugAndPlayDevices... DIFXAPP: ERROR: RETURN UpdateDriverForPlugAndPlayDevices. (Error code 0xE0000100: The style of the INF is different than what was requested.)
Note: The component here, "prl_dd.inf_x86_neutral_caed5e8e38ace253", is just an example. You need to check the parallels-tools-setup.log in order to find the exact component that cannot be installed in your case.
Cause
One or several files containing the cache for Parallels drivers are damaged as a result of an incorrect virtual machine shutdown or crash during Parallels Tools installation.
Resolution
Note: We highly recommend that you back up your virtual machine before continuing with these instructions.
Note: This solution applies to Windows 7 only
Section 1.
- Upgrade your Windows 7 to Windows 7 Service Pack 1.
- Restart Windows and check to see if the issue persists. Proceed with Section 2 if it does.
Section 2.
- Remove Parallels Tools via the Control Panel.
- Reboot Windows in your virtual machine.
- Install Parallels Tools again using Parallels Desktop menu (Virtual Machine --> Install Parallels Tools).
- Refer to Section 3 if the problem persists.
Section 3.
- Open the C:\Windows\System32\DriverStore\FileRepository folder.
- Find the prl_dd.inf_x86_neutral_caed5e8e38ace253 folder. The exact name can be found in the log file (see the Sample above).
- Change permissions of the folder C:\Windows\System32\DriverStore\FileRepository\prl_dd.inf_x86_neutral_caed5e8e38ace25. Select Administrators and allow Full access (right-click on the folder, and choose Properties --> Security).
- Remove this folder.
- Install Parallels Tools again using the Parallels Desktop menu (Virtual Machine --> Install Parallels Tools).
If you have a Windows 7 virtual machine and neither of these solutions worked for you, please follow these steps:
- This solution will work only if the error is present in the log file:
Could not open file C:\Windows\System32\DriverStore\FileRepository\prl_mouf.inf_x86_neutral_2209e2708eaa50e2\prl_mouf.inf. (Error code 0x3: The system cannot find the path specified.)
- Open the C:\Windows\System32\DriverStore folder.
- Find the infstor.dat, infstrng.dat and INFCACHE.1 files.
- Change its permissions: right-click on each of files, choose Properties --> Security, choose Administrators, and allow Full access.
- Rename this file (e.g., to "1infstor.dat").
NOTE: Renaming the infstor.dat, infstrng.dat and INFCACHE.1 files is a temporary workaround. Do not remove it if Section 1 or 2 managed to fix your problem.
IMPORTANT: Do not remove the above stated files as it may lead the BSOD error message to appear in your Virtual Machine.
- Install Parallels Tools again using the Parallels Desktop menu (Virtual Machine --> Install Parallels Tools).
No
Yes